« 日経TRENDY 2010年9月号は、iPhoneアプリの比較 | トップページ | ノートパソコン用冷却台 ELECOM 冷え冷えクーラー SX-CL06SV »

2010年8月22日 (日)

Firefoxを3.6にしたら、いくつかのアドオンが動かなくなった

遅まきながらWindows 7のFirefoxを3.5.xから3.6.8にアップデートした。
Windows XPでは、FF3.6で不具合はなかったので、
Win7でも、いよいよってこと。

しかし、次のアドオンが動かなくなった。

  • CuteMenus Classic
  • IE Tab
  • Password Bank

CuteMenus Classic

CuteMenus Classicは、代わりのアドオンとして「CuteMenus - Crystal SVG」を
インストールしてみた。

しかし、メニューの表示がおかしくなるので、NG。

まぁ、このアドオンは、見た目だけなので、なくても問題ない。
ということで、現在、Cuteじゃないメニューとなっている。

IE Tab

IE Tab自身はFF3.6には未対応だが、
FF3.6対応の後継アドオンとして、「IE Tab 2」と「IE Tab Plus」がある。
両者の違いは、こちらの記事に書かれている。

で、この記事を参考に、互換性を重視して「IE Tab 2」をインストールした。

IE Tab 2の設定画面を開くと、
『古いIE Tabの設定をインポートするか?』って聞いてくれ、
設定を引き継ぐことができた。

Password Bank

と、ここまでは、まぁ、この程度でよいのだが、
問題は、Password Bank。

Password Bankは、Webページ上のパスワードなどを
指紋認識と連動して自動入力してくれるアドオン。
UPEKのProtector Suiteの機能。

Mozillaのアドオンサイトではアップデートできない。
なので、調べてみたら、こちらの記事にヒントがあった。

この記事によると、FF3.6用のPassword Bankアドオン「pbff3.6.xpi」が
UPEKのサイトで公開されてるってこと。
Win7にインストールしてあるProtector SuiteのバージョンはOK。
なので、早速 pbff3.6.xpi をFF3.6にインストールしてみた。

そして、FF3.6を再起動すると、、、

Passwordbankerr

この拡張機能は、インストールしたパスワードバンクで使用するためのものではありません。このFirefox拡張機能をアップグレードしてください。

はぁ? 意味わかんねぇ。
FF3.6対応版をインストールしたのに、アップグレードしろだって。
Protector Suiteのバージョンか?
でも、pbff3.6.xpiの説明にあるとおり、5.9.2を使ってるぞ。

しかたがないので、ヒントにした記事にあった
別の対応方法を試した。

といっても、Protector Suiteは、
最初から対応済みバージョンだったので、
その次の手順から実施。

やったことを要約すると、Protector Suiteの最新の無料試用版から
「pwbank.dll」を抜き出して、現在のものと置き換え。

で、なんと、この方法で、上記ダイアログは表示されなくなり、
FF3.6で、無事、Password Bankが動くようになった。

やっぱり、上のダイアログは、
インストールされてるProtector Suiteと、
FFのアドオンのPassword Bankとで、
バージョンがあってない、ってことだったのか?

よく分からないが、動くようになったので、めでたし。

外部リンク:

« 日経TRENDY 2010年9月号は、iPhoneアプリの比較 | トップページ | ノートパソコン用冷却台 ELECOM 冷え冷えクーラー SX-CL06SV »

パソコン・インターネット」カテゴリの記事

2021年6月
    1 2 3 4 5
6 7 8 9 10 11 12
13 14 15 16 17 18 19
20 21 22 23 24 25 26
27 28 29 30      

Amazonリンク

ダイビング写真(swf)

ブログ内検索

  • Google
    WWW を検索
    ブログ内を検索

リンク(いつもお世話さま)

  • ソニーストア
     iTunes Store(Japan)
    Just MyShop(ジャストシステム)
    ブックオフオンライン
無料ブログはココログ